Monthly Archives: abril 2015

Modificando la prioridad de paquetes APT

Esta necesidad surge como consecuencia de intentar actualizar Mariadb en un Debian Wheezy y el hecho de que el paquete libmysqlclient18 de Wheezy para MySQL entra en conflicto con el que está incluido en los repositorios de Mariadb.

El paquete provisto por Maria debería tener una “prioridad” más alta pero si ambos están “empatados” el sistema se decanta por la opción equivocada, esto puede ser verificado de esta manera:

# apt-cache policy libmysqlclient18
 libmysqlclient18:
 Installed: 5.5.24+dfsg-9
 Candidate: 5.5.24+dfsg-9
 Version table:
 5.5.28+dfsg-1 0
 996 http://ftp2.fr.debian.org/debian/ sid/main amd64 Packages
 5.5.28-mariadb1~wheezy 0
 500 http://mirror.jmu.edu/mariadb/repo/5.5/debian/
 wheezy/main amd64 Packages
 *** 5.5.24+dfsg-9 0
 999 http://cdn.debian.net/debian/ wheezy/main amd64 Packages
 100 /var/lib/dpkg/status

El candidato debería ser 5.5.28-mariadb1~wheezy en ese caso, se puede marcar el paquete Mariadb con una prioridad más alta pero esto debería ser corregido para que no sea necesario forzar las prioridades de los paquetes.

Esta es una solución rápida (no olviden ajustar el repo de Maria por el que están usando) :

#echo -e "Package: libmysqlclient18\nPin: origin mirror.jmu.edu\nPin-Priority: 1000" > /etc/apt/preferences.d/mariadb-mysqlclient18

Luego se puede verificar con “apt-cache policy libmysqlclient18” que el paquete candidato es el correcto esta vez y la instalación ahora debería funcionar correctamente.

Base de Conocimiento de mariadb.com

Publicado en Miniguías Etiquetado con: , , ,